Scheduled Maintenance 11/4 at 7am ET

Scheduled for Nov 4, 07:00 - 08:00 EST

Update

Due to recent issues at Amazon Web Services (AWS), we are postponing this scheduled maintenance until November 4th.
Posted Oct 20, 2025 - 15:54 EDT

Scheduled

SecureGive will be executing scheduled updates during this period. All recurring transactions for this day will still process as normal. Anyone accessing the system during this time may see a brief maintenance window until the update is complete.
Posted Nov 04, 2025 - 07:00 EST
This scheduled maintenance affects: Online, Text to Give, Kiosk - iPad, Kiosk - Windows, Mobile App - iOS, Mobile App - Android, and Crypto.